Photobucket
Photobucket
Members Login
Post Info TOPIC: Transmission Issue


Veteran Member

Status: Offline
Posts: 77
Date:
Transmission Issue


My turbo 350 transmission doesn't shift into 1st until you have sat at a light for about 20 seconds? The fluid level is up, I don't think the linkage position would affect it?

In automatic mode it wouldn't stay in low past 3000 RPM under full throttle, in spite of adjusting the linkage which doesn't seem to make any difference. 

Any ideas?



__________________


Addicted!

Status: Offline
Posts: 478
Date:

HOW IS THE FILTER ?? BLOCKED??

SEAL LEAKING?



__________________


Canadian Poncho Superstar!

Status: Offline
Posts: 5345
Date:

What about your vacuum line? Is it intact?

__________________
70 2+2 convertible
70 2+2 hardtop
70 Parisienne hardtop
72 GMC Sierra

 

 



Veteran Member

Status: Offline
Posts: 77
Date:

Vacuum line is intact,I don't know if the filter is blocked I will have to get it up in a hoist

__________________


Addicted!

Status: Offline
Posts: 195
Date:

Sounds like it could be a governor problem. If theres room you can change it with the transmission in the car. The weights could be sticking or worn on the pivots causing the transmission to not shift properly.

Paul

__________________


Veteran Member

Status: Offline
Posts: 77
Date:

It turned out to be a stuck governor, cleaned it up and now it works great! 



-- Edited by zak404 on Friday 14th of June 2019 07:29:55 PM

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us
.
Support Canadian Poncho!
Select Amount:
.
.
.